it-swarm-es.tech

code :: bloques en Xenial Beta

Intentando instalar code :: blocks a través del PPA con apt-get y no tener mucha suerte. Sigo recibiendo estos errores:

The following packages have unmet dependencies.
libcodeblocks0 : Depends: libwxbase2.8-0 (>= 2.8.12.1+dfsg2) but it is not installable
                 Depends: libwxgtk2.8-0 (>= 2.8.12.1+dfsg2) but it is not installable
                 Recommends: codeblocks but it is not going to be installed

También he intentado instalar a través de Synaptic pero fue en vano. ¿Alguien tiene alguna idea?

¡Gracias por adelantado!

3
Persistence

Para instalar Code :: Blocks, debe ser un poco creativo, ya que primero descargue los paquetes para Ubuntu 15.10 desde aquí (simplemente busque libwxgtk2.8-). Para un sistema de 64 bits, también puede usar los siguientes enlaces para descargar los paquetes. Mejor haga los comandos ahora establecidos en un directorio separado para que no instale ninguna otra descarga que haya hecho antes.

wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxgtk2.8-dbg_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxgtk2.8-dev_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxbase2.8-dbg_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/wx2.8-headers_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb

Ahora puedes ir e instalarlos de la siguiente manera:

dpkg -i wx2.8-headers_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
dpkg -i libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
dpkg -i libwxbase2.8-dbg_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
dpkg -i libwxgtk2.8-dbg_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
dpkg -i libwxgtk2.8-dev_2.8.12.1+dfsg2-2ubuntu2_AMD64.deb
1
Videonauth

Esto es un error en el paquete de Ubuntu (supongo) o un error en code :: blocks. Sin embargo, la gente de Debian compila contra wxWidgets 3.0, así que voy con un error en el paquete de ubuntu. Recomiendo contactando al propietario del PPA y señalando el problema.

0
Seth