it-swarm-es.tech

No se puede instalar el paquete Debian

Estoy tratando de crear e instalar mi propio paquete de deb: fotorator_1.0-1.deb. Cuando intento usar gdebi fotorator_1.0-1.deb, aparece el siguiente error:

[email protected]:~/Desktop# gdebi fotorator_1.0-1.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
This package is uninstallable
Cannot install 'libgl1-mesa-glx-lts-utopic'
[email protected]:~/Desktop#

También intenté usar dpkg -i fotorator_1.0-1.deb y luego apt-get -f install. Tengo:

[email protected]:~/Desktop# dpkg -i fotorator_1.0-1.deb 
Selecting previously unselected package fotorator.
(Reading database ... 156359 files and directories currently installed.)
Preparing to unpack fotorator_1.0-1.deb ...
Unpacking fotorator (1.0-1) ...
dpkg: dependency problems prevent configuration of fotorator:
 fotorator depends on libavcodec54; however:
  Package libavcodec54:i386 is not installed.
 fotorator depends on libgl1-mesa-glx-dbg; however:
  Package libgl1-mesa-glx-dbg is not installed.
 fotorator depends on libgl1-mesa-glx-lts-utopic; however:
  Package libgl1-mesa-glx-lts-utopic is not installed.
 fotorator depends on libgl1-mesa-glx-lts-vivid; however:
  Package libgl1-mesa-glx-lts-vivid is not installed.
 fotorator depends on libglapi-mesa-dbg; however:
  Package libglapi-mesa-dbg is not installed.
 fotorator depends on libglapi-mesa-lts-utopic; however:
  Package libglapi-mesa-lts-utopic is not installed.
 fotorator depends on libglapi-mesa-lts-vivid; however:
  Package libglapi-mesa-lts-vivid is not installed.

dpkg: error processing package fotorator (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 fotorator

Y después de esto, apt-get -f install elimina mi paquete. Necesito un paquete para tener esas dependencias:

chise-db, libatk1.0-0, libavcodec54, libavcodec-extra-54, libavformat54, libavutil52, libbz2-1.0, libc6, libcairo2, libcairo2-dbg, libcgmanager0, libdatrie1, libdbus-1-3, libdc1394-22, libdrm2, libexpat1, libffi6, libffi6-dbg, libfontconfig1, libfreetype6, libgcc1, libgcc1-dbg, libgcrypt11, libgdk-pixbuf2.0-0, libgl1-mesa-glx, libgl1-mesa-glx-dbg, libgl1-mesa-glx-lts-utopic, libgl1-mesa-glx-lts-vivid, libgl1-mesa-glx-lts-wily, libglapi-mesa, libglapi-mesa-dbg, libglapi-mesa-lts-utopic, libglapi-mesa-lts-vivid, libglapi-mesa-lts-wily, libglib2.0-0, libglu1-mesa, libgnutls26, libgpg-error0, libgraphite2-3, libgsm1, libgtk2.0-0, libgtk2.0-0-dbg, libgtkglext1, libgtkglext1-dbg, libharfbuzz0b, libice6, libice6-dbg, libilmbase6, libjasper1, libjbig0, libjpeg-turbo8, liblzma5, libmp3lame0, libnih1, libnih-dbus1, libogg0, libogg-dbg, libopencore-amrnb0, libopencore-amrwb0, libopencv-core2.4, libopencv-highgui2.4, libopencv-imgproc2.4, libopenexr6, libopenjpeg2, libopus0, liborc-0.4-0, libp11-kit0, libpango-1.0-0, libpango1.0-0-dbg, libpangocairo-1.0-0, libpangoft2-1.0-0, libpangox-1.0-0, libpcre3, libpcre3-dbg, libpixman-1-0, libpixman-1-0-dbg, libpng12-0, libraw1394-11, librtmp0, libschroedinger-1.0-0, libselinux1, libsm6, libsm6-dbg, libspeex1, libspeex-dbg, libstdc++6, libstdc++6-4.8-dbg, libswscale2, libtasn1-6, libtbb2, libthai0, libtheora0, libtiff5, libudev1, libusb-1.0-0, libusb-1.0-0-dbg, libuuid1, libv4l-0, libv4lconvert0, libva1, libvo-aacenc0, libvo-amrwbenc0, libvorbis0a, libvorbisenc2, libvpx1, libvpx1-dbg, libx11-6, libx11-6-dbg, libx11-xcb1, libx11-xcb1-dbg, libx264-142, libxau6, libxau6-dbg, libxcb1, libxcb-dri2-0, libxcb-dri3-0, libxcb-glx0, libxcb-present0, libxcb-render0, libxcb-shm0, libxcb-sync1, libxcomposite1, libxcomposite1-dbg, libxcursor1, libxcursor1-dbg, libxdamage1, libxdamage1-dbg, libxdmcp6, libxdmcp6-dbg, libxext6, libxext6-dbg, libxfixes3, libxi6, libxi6-dbg, libxinerama1, libxinerama1-dbg, libxmu6, libxmu6-dbg, libxrandr2, libxrandr2-dbg, libxrender1, libxrender1-dbg, libxshmfence1, libxt6, libxvidcore4, libxxf86vm1, zlib1g, libusb-0.1-4, libopenobex1, libexif12, libgphoto2-6, libgphoto2-port10, libltdl7, libpython2.7, python2.7-dbg, libdbus-glib-1-2, libdbus-glib-1-2-dbg, libenchant1c2a, libgeoclue0, libgstreamer1.0-0, libgstreamer-plugins-base1.0-0, libharfbuzz-icu0, libicu52, libjavascriptcoregtk-1.0-0, libjavascriptcoregtk-1.0-0-dbg, libsecret-1-0, libsoup2.4-1, libsqlite3-0, libwebkitgtk-1.0-0, libwebkitgtk-1.0-0-dbg, libwebp5, libxml2, libxslt1.1

salida completa de apt-get install (lista delimitada por espacios de paquetes de dependencias):

[email protected]:~# apt-get install chise-db libatk1.0-0 libavcodec54 libavcodec-extra-54 libavformat54 libavutil52 libbz2-1.0 libc6 libcairo2 libcairo2-dbg libcgmanager0 libdatrie1 libdbus-1-3 libdc1394-22 libdrm2 libexpat1 libffi6 libffi6-dbg libfontconfig1 libfreetype6 libgcc1 libgcc1-dbg libgcrypt11 libgdk-pixbuf2.0-0 libgl1-mesa-glx libgl1-mesa-glx-dbg libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-vivid libgl1-mesa-glx-lts-wily libglapi-mesa libglapi-mesa-dbg libglapi-mesa-lts-utopic libglapi-mesa-lts-vivid libglapi-mesa-lts-wily libglib2.0-0 libglu1-mesa libgnutls26 libgpg-error0 libgraphite2-3 libgsm1 libgtk2.0-0 libgtk2.0-0-dbg libgtkglext1 libgtkglext1-dbg libharfbuzz0b libice6 libice6-dbg libilmbase6 libjasper1 libjbig0 libjpeg-turbo8 liblzma5 libmp3lame0 libnih1 libnih-dbus1 libogg0 libogg-dbg libopencore-amrnb0 libopencore-amrwb0 libopencv-core2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopenexr6 libopenjpeg2 libopus0 liborc-0.4-0 libp11-kit0 libpango-1.0-0 libpango1.0-0-dbg libpangocairo-1.0-0 libpangoft2-1.0-0 libpangox-1.0-0 libpcre3 libpcre3-dbg libpixman-1-0 libpixman-1-0-dbg libpng12-0 libraw1394-11 librtmp0 libschroedinger-1.0-0 libselinux1 libsm6 libsm6-dbg libspeex1 libspeex-dbg libstdc++6 libstdc++6-4.8-dbg libswscale2 libtasn1-6 libtbb2 libthai0 libtheora0 libtiff5 libudev1 libusb-1.0-0 libusb-1.0-0-dbg libuuid1 libv4l-0 libv4lconvert0 libva1 libvo-aacenc0 libvo-amrwbenc0 libvorbis0a libvorbisenc2 libvpx1 libvpx1-dbg libx11-6 libx11-6-dbg libx11-xcb1 libx11-xcb1-dbg libx264-142 libxau6 libxau6-dbg libxcb1 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcomposite1 libxcomposite1-dbg libxcursor1 libxcursor1-dbg libxdamage1 libxdamage1-dbg libxdmcp6 libxdmcp6-dbg libxext6 libxext6-dbg libxfixes3 libxi6 libxi6-dbg libxinerama1 libxinerama1-dbg libxmu6 libxmu6-dbg libxrandr2 libxrandr2-dbg libxrender1 libxrender1-dbg libxshmfence1 libxt6 libxvidcore4 libxxf86vm1 zlib1g libusb-0.1-4 libopenobex1 libexif12 libgphoto2-6 libgphoto2-port10 libltdl7 libpython2.7 python2.7-dbg libdbus-glib-1-2 libdbus-glib-1-2-dbg libenchant1c2a libgeoclue0 libgstreamer1.0-0 libgstreamer-plugins-base1.0-0 libharfbuzz-icu0 libicu52 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-1.0-0-dbg libsecret-1-0 libsoup2.4-1 libsqlite3-0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-0-dbg libwebp5 libxml2 libxslt1.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libatk1.0-0 is already the newest version.
libatk1.0-0 set to manually installed.
libbz2-1.0 is already the newest version.
libdatrie1 is already the newest version.
libdatrie1 set to manually installed.
libdbus-glib-1-2 is already the newest version.
libdbus-glib-1-2-dbg is already the newest version.
libdbus-glib-1-2-dbg set to manually installed.
libenchant1c2a is already the newest version.
libenchant1c2a set to manually installed.
libexif12 is already the newest version.
libexif12 set to manually installed.
libgeoclue0 is already the newest version.
libgeoclue0 set to manually installed.
libglu1-mesa is already the newest version.
libglu1-mesa set to manually installed.
libgpg-error0 is already the newest version.
libice6 is already the newest version.
libice6 set to manually installed.
libice6-dbg is already the newest version.
libice6-dbg set to manually installed.
libilmbase6 is already the newest version.
libilmbase6 set to manually installed.
libjpeg-turbo8 is already the newest version.
libjpeg-turbo8 set to manually installed.
libltdl7 is already the newest version.
libltdl7 set to manually installed.
liblzma5 is already the newest version.
libnih-dbus1 is already the newest version.
libnih1 is already the newest version.
libogg-dbg is already the newest version.
libogg-dbg set to manually installed.
libogg0 is already the newest version.
libogg0 set to manually installed.
libopenexr6 is already the newest version.
libopenexr6 set to manually installed.
libopenobex1 is already the newest version.
libopenobex1 set to manually installed.
libopus0 is already the newest version.
libopus0 set to manually installed.
liborc-0.4-0 is already the newest version.
liborc-0.4-0 set to manually installed.
libp11-kit0 is already the newest version.
libpangox-1.0-0 is already the newest version.
libpangox-1.0-0 set to manually installed.
libraw1394-11 is already the newest version.
libraw1394-11 set to manually installed.
librtmp0 is already the newest version.
libsecret-1-0 is already the newest version.
libsecret-1-0 set to manually installed.
libsm6 is already the newest version.
libsm6 set to manually installed.
libsm6-dbg is already the newest version.
libsm6-dbg set to manually installed.
libsoup2.4-1 is already the newest version.
libsoup2.4-1 set to manually installed.
libspeex-dbg is already the newest version.
libspeex-dbg set to manually installed.
libspeex1 is already the newest version.
libspeex1 set to manually installed.
libthai0 is already the newest version.
libthai0 set to manually installed.
libtheora0 is already the newest version.
libtheora0 set to manually installed.
libusb-0.1-4 is already the newest version.
libusb-1.0-0 is already the newest version.
libusb-1.0-0-dbg is already the newest version.
libusb-1.0-0-dbg set to manually installed.
libv4l-0 is already the newest version.
libv4l-0 set to manually installed.
libv4lconvert0 is already the newest version.
libv4lconvert0 set to manually installed.
libvorbis0a is already the newest version.
libvorbis0a set to manually installed.
libvorbisenc2 is already the newest version.
libvorbisenc2 set to manually installed.
libvpx1 is already the newest version.
libvpx1 set to manually installed.
libvpx1-dbg is already the newest version.
libvpx1-dbg set to manually installed.
libwebp5 is already the newest version.
libwebp5 set to manually installed.
libx11-6 is already the newest version.
libx11-6-dbg is already the newest version.
libx11-6-dbg set to manually installed.
libx11-xcb1 is already the newest version.
libx11-xcb1 set to manually installed.
libx11-xcb1-dbg is already the newest version.
libx11-xcb1-dbg set to manually installed.
libxau6 is already the newest version.
libxau6-dbg is already the newest version.
libxau6-dbg set to manually installed.
libxcb-dri2-0 is already the newest version.
libxcb-dri2-0 set to manually installed.
libxcb-dri3-0 is already the newest version.
libxcb-dri3-0 set to manually installed.
libxcb-glx0 is already the newest version.
libxcb-glx0 set to manually installed.
libxcb-present0 is already the newest version.
libxcb-present0 set to manually installed.
libxcb-render0 is already the newest version.
libxcb-render0 set to manually installed.
libxcb-shm0 is already the newest version.
libxcb-shm0 set to manually installed.
libxcb-sync1 is already the newest version.
libxcb-sync1 set to manually installed.
libxcb1 is already the newest version.
libxcomposite1 is already the newest version.
libxcomposite1 set to manually installed.
libxcomposite1-dbg is already the newest version.
libxcomposite1-dbg set to manually installed.
libxcursor1 is already the newest version.
libxcursor1 set to manually installed.
libxcursor1-dbg is already the newest version.
libxcursor1-dbg set to manually installed.
libxdamage1 is already the newest version.
libxdamage1 set to manually installed.
libxdamage1-dbg is already the newest version.
libxdamage1-dbg set to manually installed.
libxdmcp6 is already the newest version.
libxdmcp6-dbg is already the newest version.
libxdmcp6-dbg set to manually installed.
libxinerama1 is already the newest version.
libxinerama1 set to manually installed.
libxinerama1-dbg is already the newest version.
libxinerama1-dbg set to manually installed.
libxmu6 is already the newest version.
libxmu6 set to manually installed.
libxmu6-dbg is already the newest version.
libxmu6-dbg set to manually installed.
libxrandr2 is already the newest version.
libxrandr2 set to manually installed.
libxrandr2-dbg is already the newest version.
libxrandr2-dbg set to manually installed.
libxshmfence1 is already the newest version.
libxshmfence1 set to manually installed.
libxslt1.1 is already the newest version.
libxslt1.1 set to manually installed.
libxt6 is already the newest version.
libxt6 set to manually installed.
libxxf86vm1 is already the newest version.
libxxf86vm1 set to manually installed.
zlib1g is already the newest version.
chise-db is already the newest version.
chise-db set to manually installed.
libdc1394-22 is already the newest version.
libdc1394-22 set to manually installed.
libgsm1 is already the newest version.
libgsm1 set to manually installed.
libgtkglext1 is already the newest version.
libgtkglext1 set to manually installed.
libgtkglext1-dbg is already the newest version.
libgtkglext1-dbg set to manually installed.
libmp3lame0 is already the newest version.
libmp3lame0 set to manually installed.
libopencore-amrnb0 is already the newest version.
libopencore-amrnb0 set to manually installed.
libopencore-amrwb0 is already the newest version.
libopencore-amrwb0 set to manually installed.
libopencv-core2.4 is already the newest version.
libopencv-core2.4 set to manually installed.
libopencv-highgui2.4 is already the newest version.
libopencv-highgui2.4 set to manually installed.
libopencv-imgproc2.4 is already the newest version.
libopencv-imgproc2.4 set to manually installed.
libopenjpeg2 is already the newest version.
libopenjpeg2 set to manually installed.
libschroedinger-1.0-0 is already the newest version.
libschroedinger-1.0-0 set to manually installed.
libtbb2 is already the newest version.
libtbb2 set to manually installed.
libva1 is already the newest version.
libva1 set to manually installed.
libvo-aacenc0 is already the newest version.
libvo-aacenc0 set to manually installed.
libvo-amrwbenc0 is already the newest version.
libvo-amrwbenc0 set to manually installed.
libx264-142 is already the newest version.
libx264-142 set to manually installed.
libxvidcore4 is already the newest version.
libxvidcore4 set to manually installed.
libc6 is already the newest version.
libcairo2 is already the newest version.
libcairo2 set to manually installed.
libcairo2-dbg is already the newest version.
libcairo2-dbg set to manually installed.
libcgmanager0 is already the newest version.
libdbus-1-3 is already the newest version.
libdrm2 is already the newest version.
libexpat1 is already the newest version.
libffi6 is already the newest version.
libffi6-dbg is already the newest version.
libffi6-dbg set to manually installed.
libfontconfig1 is already the newest version.
libfontconfig1 set to manually installed.
libfreetype6 is already the newest version.
libfreetype6 set to manually installed.
libgcc1 is already the newest version.
libgcc1-dbg is already the newest version.
libgcc1-dbg set to manually installed.
libgcrypt11 is already the newest version.
libgdk-pixbuf2.0-0 is already the newest version.
libgdk-pixbuf2.0-0 set to manually installed.
libgl1-mesa-glx-lts-wily is already the newest version.
libgl1-mesa-glx-lts-wily set to manually installed.
libglapi-mesa-lts-wily is already the newest version.
libglapi-mesa-lts-wily set to manually installed.
libglib2.0-0 is already the newest version.
libgnutls26 is already the newest version.
libgphoto2-6 is already the newest version.
libgphoto2-6 set to manually installed.
libgphoto2-port10 is already the newest version.
libgphoto2-port10 set to manually installed.
libgraphite2-3 is already the newest version.
libgraphite2-3 set to manually installed.
libgstreamer-plugins-base1.0-0 is already the newest version.
libgstreamer-plugins-base1.0-0 set to manually installed.
libgstreamer1.0-0 is already the newest version.
libgstreamer1.0-0 set to manually installed.
libgtk2.0-0 is already the newest version.
libgtk2.0-0 set to manually installed.
libgtk2.0-0-dbg is already the newest version.
libgtk2.0-0-dbg set to manually installed.
libharfbuzz-icu0 is already the newest version.
libharfbuzz-icu0 set to manually installed.
libharfbuzz0b is already the newest version.
libharfbuzz0b set to manually installed.
libicu52 is already the newest version.
libicu52 set to manually installed.
libjasper1 is already the newest version.
libjasper1 set to manually installed.
libjavascriptcoregtk-1.0-0 is already the newest version.
libjavascriptcoregtk-1.0-0 set to manually installed.
libjavascriptcoregtk-1.0-0-dbg is already the newest version.
libjavascriptcoregtk-1.0-0-dbg set to manually installed.
libjbig0 is already the newest version.
libjbig0 set to manually installed.
libpango-1.0-0 is already the newest version.
libpango-1.0-0 set to manually installed.
libpango1.0-0-dbg is already the newest version.
libpango1.0-0-dbg set to manually installed.
libpangocairo-1.0-0 is already the newest version.
libpangocairo-1.0-0 set to manually installed.
libpangoft2-1.0-0 is already the newest version.
libpangoft2-1.0-0 set to manually installed.
libpcre3 is already the newest version.
libpcre3-dbg is already the newest version.
libpcre3-dbg set to manually installed.
libpixman-1-0 is already the newest version.
libpixman-1-0 set to manually installed.
libpixman-1-0-dbg is already the newest version.
libpixman-1-0-dbg set to manually installed.
libpng12-0 is already the newest version.
libpython2.7 is already the newest version.
libpython2.7 set to manually installed.
libselinux1 is already the newest version.
libsqlite3-0 is already the newest version.
libstdc++6 is already the newest version.
libstdc++6-4.8-dbg is already the newest version.
libstdc++6-4.8-dbg set to manually installed.
libtasn1-6 is already the newest version.
libtiff5 is already the newest version.
libtiff5 set to manually installed.
libudev1 is already the newest version.
libuuid1 is already the newest version.
libwebkitgtk-1.0-0 is already the newest version.
libwebkitgtk-1.0-0 set to manually installed.
libwebkitgtk-1.0-0-dbg is already the newest version.
libwebkitgtk-1.0-0-dbg set to manually installed.
libxext6 is already the newest version.
libxext6-dbg is already the newest version.
libxext6-dbg set to manually installed.
libxfixes3 is already the newest version.
libxfixes3 set to manually installed.
libxi6 is already the newest version.
libxi6 set to manually installed.
libxi6-dbg is already the newest version.
libxi6-dbg set to manually installed.
libxml2 is already the newest version.
libxrender1 is already the newest version.
libxrender1 set to manually installed.
libxrender1-dbg is already the newest version.
libxrender1-dbg set to manually installed.
python2.7-dbg is already the newest version.
python2.7-dbg set to manually installed.
libavcodec-extra-54 is already the newest version.
libavcodec-extra-54 set to manually installed.
libavformat54 is already the newest version.
libavformat54 set to manually installed.
libavutil52 is already the newest version.
libavutil52 set to manually installed.
libswscale2 is already the newest version.
libswscale2 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavcodec-extra-54 : Conflicts: libavcodec54 but 6:9.18-0ubuntu0.14.04.1 is to be installed
 libavcodec54 : Conflicts: libavcodec-extra-54 but 6:9.18-0ubuntu0.14.04.1 is to be installed
 libgl1-mesa-dri-lts-wily : Conflicts: xorg-renamed-package-lts-utopic
                            Conflicts: xorg-renamed-package-lts-vivid
 libgl1-mesa-glx : Recommends: libgl1-mesa-dri (>= 7.2)
                   Conflicts: libgl1
 libgl1-mesa-glx-lts-utopic : Depends: libgl1-mesa-dri-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
                              Conflicts: libgl1
                              Conflicts: libgl1-mesa-glx
 libgl1-mesa-glx-lts-vivid : Depends: libgl1-mesa-dri-lts-vivid (>= 7.2) but it is not going to be installed
                             Conflicts: libgl1
                             Conflicts: libgl1-mesa-glx
                             Conflicts: xorg-renamed-package-lts-utopic
 libgl1-mesa-glx-lts-wily : Conflicts: libgl1
                            Conflicts: libgl1-mesa-glx
                            Conflicts: xorg-renamed-package-lts-utopic
                            Conflicts: xorg-renamed-package-lts-vivid
 libglapi-mesa-lts-utopic : Conflicts: libglapi-mesa
 libglapi-mesa-lts-vivid : Conflicts: libglapi-mesa
                           Conflicts: xorg-renamed-package-lts-utopic
 libglapi-mesa-lts-wily : Conflicts: libglapi-mesa
                          Conflicts: xorg-renamed-package-lts-utopic
                          Conflicts: xorg-renamed-package-lts-vivid
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
[email protected]:~# 
3
Sxl

He eliminado paquetes que tenían conflictos de la lista de dependencias. No sé si esa es la solución correcta, pero funciona.

0
Sxl