it-swarm-es.tech

Eclipse: ¿Cómo puedo cambiar una 'Faceta del proyecto' de Tomcat 6 a Tomcat 5.5?

(Eclipse 3.4, Ganimedes)

Tengo un proyecto de aplicación web dinámica en Eclipse. Cuando creé el proyecto, especifiqué 'Configuración predeterminada para Apache Tomcat v6' en el menú desplegable 'Configuración'.

Es un mes o 2 más adelante, y ahora me gustaría cambiar la configuración a Tomcat 'v5.5'. (Esta será la versión de Tomcat en el servidor de producción).

He intentado los siguientes pasos (sin éxito):

  • Seleccioné Targeted Runtimes bajo el Proyecto Properties
    La opción Tomcat v5.5 fue desactivada y la interfaz de usuario mostró este mensaje:
    If the runtime you want to select is not displayed or is disabled you may need to uninstall one or more of the currently installed project facets.
  • Luego hice clic en el enlace Uninstall Facets....
    En la pestaña Runtimes, solo se muestra Tomcat 6.
    Para Dynamic Web Module, seleccioné la versión 2.4 en lugar de 2.5.
    En la pestaña Runtimes, ahora se muestra Tomcat 5.5.
    Sin embargo, la interfaz de usuario ahora muestra este mensaje:
    Cannot change version of project facet Dynamic Web Module to 2.4.
    El botón Finish estaba desactivado, así que llegué a un callejón sin salida.

PUEDO crear con éxito un NUEVO Proyecto con una configuración Tomcat v5.5. Sin embargo, por alguna razón, no me permitirá degradar 'un proyecto existente.

Como solución alternativa, creé un nuevo proyecto y copié los archivos de origen del proyecto anterior. No obstante, la solución fue bastante dolorosa y algo torpe.

¿Alguien puede explicar cómo puedo "degradar" la configuración del Proyecto de "Tomcat 6" a "Tomcat 5"? O tal vez arrojar algo de luz sobre por qué sucedió esto?

Gracias
Pete

56
user13360

Esto es una especie de pirateo de Eclipse y puede meterse en problemas al hacer esto, pero esto debería funcionar:

Abra la vista del navegador y descubra que hay una carpeta .settings en su proyecto expandiéndola y luego abra el archivo: org.Eclipse.wst.common.project.facet.core.xml debería ver una línea que dice: <installed facet="jst.web" version="2.5"/> Cambie eso a 2.4 y guárdelo.

Solo asegúrate de que tu proyecto no esté usando nada específico para 2.5 y debes ser bueno.

También compruebe que su web.xml tiene la configuración correcta:

<web-app version="2.4" 
        xmlns="http://Java.Sun.com/xml/ns/j2ee" 
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
        xsi:schemaLocation="http://Java.Sun.com/xml/ns/j2ee http://Java.Sun.com/xml/ns/j2ee/web-app_2_4.xsd">
87
William

Esto puede ser viejo pero probé y encontré lo siguiente en Eclipse Galilio.

Abra la vista del navegador y descubra que hay una carpeta .settings en su proyecto, expándala y luego abra el archivo: org.Eclipse.wst.common.project.facet.core.Elimine el contenido de este archivo y haga clic derecho en el proyecto y haga clic en propiedades. Ir a Project Facats en la ventana emergente allí puede hacer clic en las pestañas de tiempo de ejecución y convertir su proyecto a la nueva faceta que desee.

7
Venkat

si está utilizando Maven, cierre Eclipse, escriba >mvn Eclipse:eclipse -Dwtpversion=2.0 y reinicie Eclipse.

5
Karthik

Puede intentar desmarcar la faceta, aplicar, cambiar el valor de la faceta y marcar. Funciona para mí en Eclipse Helios SR1.

Así que la principal diferencia es que lo hago con 'Dynamic Web Module'.

Espero que funcione para ti tambien.

0
xgomez

Vi lo mismo, luego cambié el valor de la versión de la aplicación web en el web.xml. Hacerlo podría arreglar esto para ti.

0
sarabrab

Lo siento, parece que no puedo publicar un comentario sin suficiente Rep así que ...

Creo que es demasiado difícil para Eclipse degradarse de manera segura a un estándar más bajo porque realmente no puede saber si has usado algo del nuevo estándar web. Entonces, si solo le permite hacerlo, podría hacer que su programa falle en una versión anterior.

Siempre puede ser compatible con versiones anteriores pero no compatibles con versiones anteriores.

0
William