it-swarm-es.tech

en la interfaz no recibí nada más que un signo ">"

Acabo de diseñar mi sitio web fuera de línea y cuando intenté hacerlo en línea no obtuve nada más que un signo ">" en la página. Obtuve el backend del sitio correctamente, pero no sé qué pasó con la interfaz. Cuando cambié la plantilla a la plantilla predeterminada, el problema se resolvió. Y cuando cambio el informe de errores al modo de desarrollo, recibo mucho de este error:

Estándares estrictos: solo las variables deben asignarse por referencia en /home/alitk/public_html/modules/mod_news_pro_gk4/helper.php en la línea 553

y

Estándares estrictos: método no estático NSP_GK4_Thumbs :: checkSpecialImages () no debe llamarse estáticamente, suponiendo $ this desde un contexto incompatible en /home/alitk/public_html/modules/mod_news_pro_gk4/gk_classes/gk.thumbs.php en la línea 127

1
user23047

Tiene una configuración diferente entre su desarrollo y su sitio de producción. A medida que está migrando de una ubicación a otra muy diferente, puede encontrar errores fatales. Debe verificar todos los requisitos del sistema en el nuevo servidor.

Por ejemplo, la extensión ionCube, utilizada en algunas extensiones comerciales cerradas, es una sorpresa desagradable común.

Para resolver el problema, comenzaría a deshabilitar los complementos del sistema no principales, uno por uno, hasta que la página se cargue correctamente. De lo contrario, intente desinstalar todas las extensiones para limitar la búsqueda, incluso si tiene que volver a una de las plantillas predeterminadas. Una vez que encuentre el problema, cree una copia de seguridad modificada desde el sitio de desarrollo.

1
Anibal

Hay varias cosas que puede probar para encontrar el problema, y ​​sin ver realmente su sitio es difícil saber qué está causando esto.

cuando cambié la plantilla a la plantilla predeterminada, el problema se resolvió.

Esto indica que el problema podría estar con su plantilla.

  1. Si es posible, cargue todo su sitio nuevamente para asegurarse de que todos los archivos se transfirieron correctamente. Sugiero usar Akeeba Backup cuando mueva su sitio a otro servidor.
  2. Asegúrese de que Joomla y sus extensiones estén actualizadas, así como la plantilla que está utilizando.
  3. Como señaló Anibal, sus servidores pueden tener diferentes configuraciones. Verifique y compare PHP y versiones de MySQL en sus servidores.
  4. Deshabilite/anule la publicación de sus complementos y módulos uno por uno, en caso de que alguno de ellos tenga un conflicto con su plantilla.
1
johanpw