it-swarm-es.tech

¿Cuál es la versión máxima de PHP que ejecutará Joomla 1.5?

Tengo un cliente con un viejo Joomla 1.5 que no quieren actualizar este año, pero su Host quiere actualizar el servidor. ¿Cuál es la versión máxima de php que ejecutará Joomla 1.5 en lugar del min que aparece en la lista?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

¿Funcionaría bien en 5.3.10? Supongo que se rompería en 5.4, pero me resulta difícil construir una máquina de prueba con versiones antiguas para probar. Entonces más preguntas por experiencia.

gracias

4
tristanbailey

Si está ejecutando Joomla 1.5.14 o a continuación entonces debe apegarse a PHP 5.2 ya que puede haber algunas funciones y/o fragmentos de código que pueden no funcionar en PHP 5.3

Sin embargo, si está ejecutando Joomla 1.5.15 o arriba , debería estar bien con la actualización a PHP 5.3. Si está utilizando la biblioteca OpenID, entonces esto no será compatible con PHP 5.3 y, por lo tanto, necesitará encontrar una alternativa o quedarse con PHP 5.2

Para obtener más información sobre qué versiones de PHP, MySQL y Apache, eche un vistazo a Requisitos técnicos

Te sugiero que actualices a Joomla 1.5.26, que es la última versión de la serie 1.5.

Espero que esto ayude

5
Lodder

Estoy ejecutando un sitio Joomla 1.5.26 junto con un nuevo sitio J3 en construcción en la misma instalación PHP. El sitio J1.5 se ejecuta perfectamente en PHP = 5.6 sin ningún cambio en absoluto. El sitio J1.5 es un sitio muy simple con solo unas pocas extensiones.

4
biltong

Confirmo que Joomla 1.5.24 se ejecuta en PHP 5.5.9-1ubuntu4.17. PHP-FPM se instaló con apt. El servidor web es nginx. Todas las características parecen funcionar sin problemas.

3
Egeshi