it-swarm-es.tech

Componente migratorio de 2.5 a 3.3

Esta documentación: Adaptando una extensión de Joomla 1.5 a Joomla 2.5

http://docs.joomla.org/Adapting_a_Joomla_1.5_extension_to_Joomla_1.6#Renamed_events

Realmente me ayudó cuando migré mi componente a 2.5.

Me pregunto si hay algo similar que le muestre cómo migrar su componente de 2.5 a 3.3

Gracias

5
Piero Marsilio

Incluso el enlace que ha proporcionado en su pregunta no proporciona todo lo que necesita ser cambiado al migrar una extensión. Siempre hay diferencias API bastante grandes entre cada versión de lanzamiento a largo plazo de Joomla.

Para Joomla 3.x, lo principal que tiendo a mirar es lo siguiente:

Posibles problemas de compatibilidad con versiones anteriores en Joomla

Además de esto, también miro el último sitio API:

http://api.joomla.org/cms-3/

Espero que esto ayude

12
Lodder

Si solo está buscando que funcione, los enlaces proporcionados por @Lodder ayudarán enormemente cuando se trata de código obsoleto. Se generó una copia de seguridad de un montón de código 3.x mientras trabajaba en 2.5.5, por lo que si solo admite esa versión o posterior, en teoría podría obtener un componente que funcione en las versiones 2.5 y 3.x con relativa facilidad. Lo que no está documentado son los cambios de diseño que vinieron con el cambio a Bootstrap; necesitará usar los componentes principales como modelo para eso.

Si está buscando agregar soporte para las características 3.x (como etiquetas o historial de contenido), tendrá que trabajar un poco más. Estos enlaces lo ayudarán a integrar el soporte para esas características:

4
Michael

Migrar componente de 2.x a 3.x

consulte este enlace,

paso 1: Diferencia entre 2.x en 3.x

paso 2: Métodos importantes

2
kumarramalingam