it-swarm-es.tech

Instalación del problema de TensorRT con la biblioteca libnvinfer7 (Cuda 10.2) en ubuntu 18.04

Intenté instalar tensorRT 7.0 en ubuntu 18.4 (nv-tensorrt-repo-ubuntu1804-cuda10.2-trt7.0.0.11-ga-20191216_1-1_AMD64.deb) debian.

Seguí la documentación https://docs.nvidia.com/deeplearning/tensorrt/install-guide/index.html#installing-debian .

Recibo el siguiente error con libnvinfer7. Buscando esto en todo el planeta, incapaz de encontrarlo, perdí mi tiempo y sueño. Amablemente ayúdame con esto:

 [email protected]:/opt/pixuate$ Sudo apt install tensorrt
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     tensorrt : Depends: libnvinfer7 (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvinfer-plugin7 (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvparsers7 (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvonnxparsers7 (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvinfer-bin (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvinfer-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvinfer-plugin-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvparsers-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvonnxparsers-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvinfer-samples (= 7.0.0-1+cuda10.2) but it is not going to be installed
                Depends: libnvinfer-doc (= 7.0.0-1+cuda10.2) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

Bueno, intenté "Sudo apt-get install python3-libnvinfer-dev"

[email protected]:/opt/pixuate$ Sudo apt-get install python3-libnvinfer-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libnvinfer-dev : Depends: python3-libnvinfer (= 7.0.0-1+cuda10.2) but it is not going to be installed
                          Depends: libnvinfer-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                          Depends: libnvinfer-plugin-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                          Depends: libnvparsers-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
                          Depends: libnvonnxparsers-dev (= 7.0.0-1+cuda10.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
3
Amarnath R

En la sección de instalación de TensorRT de https://docs.nvidia.com/deeplearning/tensorrt/install-guide/index.html hay esta oración:

requiere que CUDA Toolkit y cuDNN también se hayan instalado utilizando paquetes Debian o RPM

Si instala el kit de herramientas CUDA y cuDNN utilizando archivos deb, el error de dependencias no satisfechas debería resolverse.

NOTA: Antes de instalar, verifique las versiones de Ubuntu, CUDA y cuDNN que desea instalar. En los consejos de instalación a continuación se utilizaron CUDA 10.2 y cuDNN 7.6.5. Esto está probado para TensorRT 7.0.0.

CUDA .deb install

wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804x86_64cuda-ubuntu1804.pin  
Sudo mv cuda-ubuntu1804.pin /etc/apt/preferences.d/cuda-repository-pin-600
wget http://developer.download.nvidia.com/compute/cuda/10.2/Prod/local_installers/cuda-repo-ubuntu1804-10-2-local-10.2.89-440.33.01_1.0-1_AMD64.deb
Sudo dpkg -i cuda-repo-ubuntu1804-10-2-local-10.2.89-440.33.01_1.0-1_AMD64.deb
Sudo apt-key add /var/cuda-repo-10-2-local-10.2.89-440.33.01/7fa2af80.pub
Sudo apt-get update
Sudo apt-get -y install cuda

CUDNN .deb instalar

Primero descargue los archivos .deb:

  1. cuDNN Developer Library para Ubuntu18.04 (Deb)
  2. cuDNN Runtime Library para Ubuntu18.04 (Deb)

Después de eso, instale los paquetes descargados:

Sudo dpkg -i libcudnn7_7.6.5.32-1+cuda10.2_AMD64.deb
Sudo dpkg -i libcudnn7-dev_7.6.5.32-1+cuda10.2_AMD64.deb

NOTA: Estas instrucciones de instalación son de los sitios web oficiales de nvidia

1
navi2607