it-swarm-es.tech

php5 y phpmyadmin no se instalan

He instalado mysql, mysql-server, Apache2 y muchos más. Es posible que haya instalado algunos PPA o programas incorrectos que causan este problema. Básicamente, necesito ejecutar el servidor local (por ejemplo, para WordPress). Entonces necesito localhost/phpmyadmin. De alguna manera, localhost está funcionando (muestra su página predeterminada) pero localhost/phpmyadmin no funciona.

Cuando intenté Sudo apt-get install phpmyadmin, me da el siguiente resultado

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

phpmyadmin : Depends: libapache2-mod-php5 but it is not going to be installed or
                       libapache2-mod-php5filter but it is not going to be installed or
                       php5-cgi but it is not going to be installed or
                       php5-fpm but it is not going to be installed or
                       php5 but it is not going to be installed
              Depends: php5-mysql but it is not going to be installed or
                       php5-mysqli but it is not installable or
                       php5-mysqlnd but it is not going to be installed
              Depends: php-gettext but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Cuando probé Sudo apt-get install php5 libapache2-mod-php5, aparece el siguiente error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but 5.5.9+dfsg-1ubuntu4.14 is to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Una vez más, intenté instalar phps-common faltante por Sudo apt-get install php5-commom, muestra que php5-common ya es su versión más nueva. Aquí está la salida:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but 5.5.9+dfsg-1ubuntu4.14 is to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:/$ Sudo apt-get install php5-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

Entonces, chicos, necesito su ayuda para instalar phpmyadmin.

UPDATE Aquí hay una salida de grep -R --include '*.list' '^deb ' /etc/apt

/etc/apt/sources.list:deb cdrom:[Ubuntu 14.04.3 LTS _Trusty Tahr_ - Beta AMD64 (20150805)]/ trusty main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security multiverse
/etc/apt/sources.list:deb http://extras.ubuntu.com/ubuntu trusty main
/etc/apt/sources.list:deb http://deb.torproject.org/torproject.org trusty main
/etc/apt/sources.list.d/upubuntu-com-office-trusty.list:deb http://ppa.launchpad.net/upubuntu-com/office/ubuntu trusty main
/etc/apt/sources.list.d/google.list:deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/webupd8team-sublime-text-3-trusty.list:deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-Java-trusty.list:deb http://ppa.launchpad.net/webupd8team/Java/ubuntu trusty main
/etc/apt/sources.list.d/google-chrome.list:deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/cordova-ubuntu-ppa-trusty.list:deb http://ppa.launchpad.net/cordova-ubuntu/ppa/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-tor-browser-trusty.list:deb http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu trusty main
/etc/apt/sources.list.d/nodesource.list:deb https://deb.nodesource.com/node_5.x trusty main
/etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list:deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main

y salida de apt-cache policy php5-common

php5-common:
  Installed: 5.5.9+dfsg-1ubuntu4.14
  Candidate: 5.5.9+dfsg-1ubuntu4.14
  Version table:
 *** 5.5.9+dfsg-1ubuntu4.14 0
        100 /var/lib/dpkg/status
     5.5.9+dfsg-1ubuntu4.5 0
        500 http://ubuntu.excellmedia.net/archive/ trusty-updates/main AMD64 Packages
        500 http://ubuntu.excellmedia.net/archive/ trusty-security/main AMD64 Packages
     5.5.9+dfsg-1ubuntu4 0
        500 http://ubuntu.excellmedia.net/archive/ trusty/main AMD64 Packages

ACTUALIZACIÓN 2 Aquí hay una salida de aptitude search '?narrow(?installed, !?version(CANDIDATE))'

W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main AMD64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-AMD64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to update the package lists to correct these missing files
i   google-chrome-stable            - The web browser from Google               
i   nodejs                          - Node.js event-based server-side javascript
i   Oracle-Java8-installer          - Oracle Java(TM) Development Kit (JDK) 8   
i   Oracle-Java8-set-default        - Set Oracle JDK 8 as default Java          
i   tor-browser                     - Tor Browser Bundle                        
4
Madan Bhandari

Su versión instalada de php5-common es incompatible con los paquetes que desea instalar.

Es muy probable que haya agregado un PPA, luego instaló una versión más nueva de php5-common (y tal vez otros paquetes) y eliminó o deshabilitó el PPA nuevamente.

Lo que debemos hacer ahora es eliminar esas versiones "demasiado nuevas" de su caché de paquetes para evitar otra reinstalación accidental de ellas, y luego degradar el paquete php5-common a la versión disponible desde el repositorio oficial:

Sudo apt-get clean    
Sudo apt-get install php5-common=5.5.9+dfsg-1ubuntu4.5

Solo si eso aún no funcionó, ejecute los siguientes comandos después. El último es el mismo que el anterior.

Sudo rm -rf /var/lib/apt/lists
Sudo apt-get update
Sudo apt-get install php5-common=5.5.9+dfsg-1ubuntu4.5
1
Byte Commander